Categories
apache sp1 webdav windows 7

Webdav "improvements" in Win7 SP1

I previously wrote about the problems I have had using webdav in Windows 7 to my webdav server. If you haven’t read it follow this link.

Essentialy using the Window 7 webDAV client to a server using basic authentication over SSL did not work. No matter how hard you tried.

This situation has only been slight rectified in Win7 SP1, but with other issues. When I tried to create the drive mapping to the server I get some real weirdness.

  1. When the mapping is created I get an error that the mapping already exists, which is very weird. A look under My Computer reveals three identical links have been created.
  2. Using one of the links does connect to the server and I can see the folders and files. But I cannot navigate through the folders, nor can I open and of the files! Which makes it quite useless.

I have attempted to look for a solution to this issue, but nothing has turned up so. Its entirely possible that I’m the only one encountering this problem. For the moment I’ll still keep using the 3rd party client I have been using for the past year.

Anyone with a solution please feel free to comment.

Categories
ldap MS ssl webdav windows 7

Windows 7, WebDav and basic authentication

In a recent post I gave some tips and experience on setting up a WebDAV server on lighttpd. Now one thing you noticed is that the authentication was basic. This means that the password is sent clear to the server from the client. Unfortunately most web servers which use LDAP as the authentication and authorization back end can only do so using basic authentication.

This is fine using Windows XP. Its WebDAV client doesn’t care. In Vista it will work with basic as long as the connection is encrypted. In Windows 7 it will only work with digest authentication whether or not the connection is encrypted. Well that is my expereince. If someone has a way to get the Win7 WebDAV client to work over a SSL link to a WebDAV server which uses basic authentication please tell us.

As it is we must now use 3rd party WebDAV clients. Typically you have to pay in order to get one that is at least as good as the Windows supplied client.

Microsoft please sort this issue out and take it back to the Vista functionality.