Categories
FreeBSD Linux RAID Ubuntu

A Switch for the better?

Previously I wrote about my problems with FreeBSD and one of my machines. Well the problem seemed to get worse and caused several system crashes and some data corruption. Much of the problem seemed to centre around copying large files on the single disk. This is not a good situation for a office file server. And the staff are less than impressed.

I still like FreeBSD however. It is light, its fast and relatively easy to setup and use. But it just wasn’t reliable on my hardware for some reason. Hopefully the BSD developers will figure out what the problem is and sort it out.

So, on Friday, I decided to drop BSD and go with linux. The difficult choice with linux is which distribution to go with. There are hundreds of them and dozens of server products – like SME Server – built on them. I chose to go with Ubuntu, well Xubuntu specifically, though choosing between OpenSUSE and Ubuntu is a toss up these days.

The install went very easy, getting the desktop up was easy. Next to get the 320Gig disks sorted out. I formatted on ext3 and mounted the other as a UFS2 read only partition. Copied the data over and then began to rebuild the RAID 1. There is plenty of info on software RAID in linux, but most examples deal with creating one from install. I had lost hope until I found http://www.linuxconfig.org/Linux_Software_Raid_1_Setup.

A bit of work with gparted, fdisk, sfdisk and viola! My RAID was back up. I don’t find the linux RAID as user friendly as the BSD one. Linux requires using the unfriendly tool mdadm and getting status and disk activity doesn’t appear to be as nice. So far my copying tests haven’t broken the I/O system and the RAID…we’ll see how it goes.

Overall Linux appears impressive. But I have had a couple of niggles. On one reboot the machine hung and dropped me into some system with a ‘(intramfs)’ prompt. Would like to know what that is. On another reboot the system hung on NFS restart. Clearly linux is not meant to be rebooted! Xubuntu also seems to use a lot more memory than BSD especially when running X. For that reason I have disabled the X login screen at boot.

Now to get the Samba/CIFS server back up and get my NFS back and working.

Then I have to get on to Windows 2008 Enterprise Server and Sharepoint 3. Wish me luck as I also intend to install SQL Server 2008 CTP on to it!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.